NATO Message Board Logo Dedicated to the 1983-1988 Ford Thunderbird Turbo Coupe

Previous Thread
Next Thread
Print Thread
#252909 - 09/11/17 09:42 PM Bypassing Graphic Equalizer  
Joined: Feb 2015
Posts: 212
anasazi4st Offline
Boosting 10 psi
anasazi4st  Offline
Boosting 10 psi

Joined: Feb 2015
Posts: 212
Phoenix, AZ
Hi all,

In the course of transplanting (swapping) a working cassette drive into my 1987 TC's OEM Ford Premium Sound AM/FM cassette radio, somehow I lost the FM function. AM works okay as does the newly-transferred cassette player, but something somewhere ain't right.

Lacking a schematic, I've gone over and over the radio chassis looking for something obvious...no luck so far.

Last week I visited a local Pick-A-Part DIY salvage yard, and miraculously found a Premium Sound radio in an old Bronco! Even more amazing, it still works. The problem: this radio is a rotating-knob one, and my existing setup has the sliding balance control. This means I'll most likely have to remove/bypass the graphic equalizer, which I really don't want to do.

My question is: has anyone else ever done this? While I'm intelligent enough to figure this out, it would be sooo much easier for someone else that has already done it to instruct me as to the proper method.

I know the obvious question is, "why don't you get rid of that old piece of junk and install a more modern head unit?" Easy answer--I'd like to keep everything as stock as possible. As amusing as this sounds--I don't listen to the radio all that much (I have an old Sony cassette adapter that plugs into my iPod and plays through the radio), as I generally hate commercial radio. (But we do have an amazing classic FM station here that makes all this trouble worthwhile, and is listener supported--no ads!)

Thanks in advance for whatever help/assistance you can provide.


1987 Turbo Coupe w/T5OD, 8.8 axle, grey smoke; most options. Bought in 1991 with 41K miles: 3 turbos, 2 heater cores, 1 tranny swap (and now a full rebuild), 5 clutches, 1 head gasket, 2 Teves II ABS units, etc. later....
#252911 - 09/12/17 12:41 PM Re: Bypassing Graphic Equalizer [Re: anasazi4st]  
Joined: Apr 2001
Posts: 2,526
BJL Offline
BJL  Offline



Joined: Apr 2001
Posts: 2,526
Sewell , New Jersey
with the radio out of the car. reach your arm into the slot the radio goes and follow the harness toward sthe glove box. there is another radio harness there for using with out the equalizer and has all the wires going to the speakers.


Brian J Larkin
88TC "Turbo II" Owned 10 years. 312k miles
T3, 3in stinger exhaust, gillis, 255 walbro, afpr, 5spd swap,spec clutch, sn95 5 lug, k/n,
89 Cougar XR7 3.8SC Auto
95 Ranger Splash 3.0 auto
http://s9.photobucket.com/user/BJL88TC/m...a20d48.jpg.html
#252915 - 09/13/17 05:35 AM Re: Bypassing Graphic Equalizer [Re: BJL]  
Joined: Feb 2015
Posts: 212
anasazi4st Offline
Boosting 10 psi
anasazi4st  Offline
Boosting 10 psi

Joined: Feb 2015
Posts: 212
Phoenix, AZ
Originally Posted by BJL
with the radio out of the car. reach your arm into the slot the radio goes and follow the harness toward sthe glove box. there is another radio harness there for using with out the equalizer and has all the wires going to the speakers.


Hello and thanks for the response.

I'm pretty sure that what you're describing is the AMPLIFIER BYPASS harness. When installing an aftermarket stereo (head unit or HU for short), the factory amp MUST be disabled to prevent it from conflicting with the HU's built-in amplifier. Ford thought that some (many?) would choose to go after-market and want to bypass that factory amp, so they generously provided a wiring harness that connected directly to the speakers.

That's not what I want to do. I want to bypass the GRAPHIC EQUALIZER ONLY, but keep the factory amp. Actually, I don't want to bypass it at all, I was curious if anyone has figured out a good way to do that.

I've spent quite literally hours on the Internet searching for an answer to my problem...along the way I picked up some other useful knowledge.


1987 Turbo Coupe w/T5OD, 8.8 axle, grey smoke; most options. Bought in 1991 with 41K miles: 3 turbos, 2 heater cores, 1 tranny swap (and now a full rebuild), 5 clutches, 1 head gasket, 2 Teves II ABS units, etc. later....
#252916 - 09/13/17 12:34 PM Re: Bypassing Graphic Equalizer [Re: anasazi4st]  
Joined: Apr 2001
Posts: 2,526
BJL Offline
BJL  Offline



Joined: Apr 2001
Posts: 2,526
Sewell , New Jersey
you can use the factory equalizer, just have to wire in the rca pre outs to it and plug them into the a/m radio pre outs. there was a write up about it on fox tbird cougar years ago.
i
ford manufactured the car to except both the premium soun, premium sound with eq and then base sound system, make one harness for all cars. cheaper and faster, but gave us better options if we delete the premium sound.


Brian J Larkin
88TC "Turbo II" Owned 10 years. 312k miles
T3, 3in stinger exhaust, gillis, 255 walbro, afpr, 5spd swap,spec clutch, sn95 5 lug, k/n,
89 Cougar XR7 3.8SC Auto
95 Ranger Splash 3.0 auto
http://s9.photobucket.com/user/BJL88TC/m...a20d48.jpg.html
#252918 - 09/14/17 07:41 PM Re: Bypassing Graphic Equalizer [Re: BJL]  
Joined: Feb 2015
Posts: 212
anasazi4st Offline
Boosting 10 psi
anasazi4st  Offline
Boosting 10 psi

Joined: Feb 2015
Posts: 212
Phoenix, AZ
Originally Posted by BJL
you can use the factory equalizer, just have to wire in the rca pre outs to it and plug them into the a/m radio pre outs. there was a write up about it on fox tbird cougar years ago.


As Johnny Carson would have said, "I did not know that."

And, thanks for the info from the fox tbird cougar site. I went there and read the information and I have a more clear idea of what you mean about wiring the RCA plugs, although I don't see why I'd want to do that. I don't want to install an aftermarket unit, just adapt a different model that doesn't use the equalizer.

But none of that matters. I solved my problem and everything works together pretty well. Briefly: I jumpered the switched 12V+ wire (marked IGN) from the existing wiring harness and ran it to the graphic equalizer. There are a few issues I have to correct (or learn to live with), notably the POP that hits the speakers when the ignition or ACC is activated (as my equalizer has the OBLIGATORY broken power switch, which I completely removed and soldered the inner wires together a while ago, so it's always on). This was solved with a toggle switch for the new power wire. Also, neither the fader on the equalizer or the rotating knob one on the radio work, there is now no separation between front and rear speakers. I can live with that, at least for now. It's my hope that I'll be able to locate and reinstall a Premium Sound radio with a sliding balance control like I originally had.

There's a complete write-up of how I did it, complete with photos, here. (That web address is http://broodcoffeetalk.wordpress.com .) There's some other DIY stuff, like how to resuscitate an unresponsive ammeter. I'll be adding more from my Projects folder over the next few weeks.


1987 Turbo Coupe w/T5OD, 8.8 axle, grey smoke; most options. Bought in 1991 with 41K miles: 3 turbos, 2 heater cores, 1 tranny swap (and now a full rebuild), 5 clutches, 1 head gasket, 2 Teves II ABS units, etc. later....
#252921 - 09/18/17 01:41 PM Re: Bypassing Graphic Equalizer [Re: anasazi4st]  
Joined: Apr 2001
Posts: 2,526
BJL Offline
BJL  Offline



Joined: Apr 2001
Posts: 2,526
Sewell , New Jersey
add a resistor to the remote turn on for the amp. it will eliminate that pop


Brian J Larkin
88TC "Turbo II" Owned 10 years. 312k miles
T3, 3in stinger exhaust, gillis, 255 walbro, afpr, 5spd swap,spec clutch, sn95 5 lug, k/n,
89 Cougar XR7 3.8SC Auto
95 Ranger Splash 3.0 auto
http://s9.photobucket.com/user/BJL88TC/m...a20d48.jpg.html

Moderated by  Jeff K, Pete D 

Site Links
NATO Pages
TC Technical
Google Site Search
Newest Members
nitedriver57, TC destinyman20, 23reasons, Mr. Mull, Max
5743 Registered Users
Popular Topics(Views)
50,518 please help
Shout Box
NATO Member Photos
Looks good, in the rain!
Big-Al's 88 Turbocoupe
My 1988 Turbo Coupe..forever a work in progress
Who's Online Now
1 registered members (mike schrijvers), 22 guests, and 0 spiders.
Key: Admin, Global Mod, Mod
Website Created 3-12-2000
Contents Copyright © 2000-2017
North American Turbocoupe Organization
A L L   R I G H T S   R E S E R V E D



Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.033s Queries: 14 (0.008s) Memory: 2.7006 MB (Peak: 2.8587 MB) Zlib disabled. Server Time: 2017-11-18 06:06:53 UTC